Path of Exile

3.13 Performance Feedback from Someone Playing on a Higher End Rig

Howdy.

Just want to provide some feedback on the game's performance this league.

Before we continue, here are my specs:

  • OS: Windows 10 Pro
  • Motherboard: Gigabyte Z390 GAMING X
  • CPU: Intel i9-9900KF, 8 cores @3.6Ghz, 16 threads
  • GPU: MSI GeForce RTX 2080 Ti Gaming X Trio, 11GB GDDR6
  • RAM: G.Skill Aegis 32GB (4x 8GB) DDR4-3000
  • SSD: Samsung Evo 860 1TB SATA
  • CPU Cooler: Be Quiet! Dark Rock 4
  • Case: Be Quiet! Dark Base Pro 900
  • PSU: Be Quiet! Pure Power 11 700W CM

Not OC'd, and yeah, not NVME M.2 SSD because too expensive for me right now. Still, it's a fairly powerful rig by today's standards.

The performance this league has been absolutely atrocious compared to last league. I've been streaming this game, so I can see in the videos themselves a direct comparison.

I've changed nothing in the settings, but here they are (roughly):

  • Bloom at 25%
  • Depth of Field disabled (never tried changing that one)
  • Dynamic Culling enabled
  • Dynamic Resolution disabled
  • V-Sync on
  • Edit: Yes, playing on Vulkan
  • Everything else put to max
  • 1080p 60FPS, Windowed Fullscreen (I could technically play in 4k, but it makes all the loot and stuff really tiny)

Now, down to the issues:

  • I'm now closing in on 100 crashes since the league started. Game just freezes and crashes to desktop. RAM leak was suggested, but I can't see anything. It stays below 6GB.
  • CPU sometimes runs quite hot in the 84-86°C range, but my cooler keeps it there. However, I will replace this cooler with a better one at some point. Note: I am playing quite the spammy build, so high temps were expected, but it's slightly worse than last league (~82°C).
  • Similar thing for my GPU, with temps ranging from 74-77°C.
  • Crashes also often occur during Rituals. Very annoying. Also frequently happen when looting stuff or completing a Delve node.
  • Frame rate is all over the place. When I open the Passive Tree, it sometimes drops me to below 40 FPS (seems to be a rare bug tho).
  • When I enter an area the first time, there's a slight blur effect.
  • Same blur effect sometimes occurs when I open the inventory or stash.
  • When I enter an area/map the first time in general, the game needs a good 5-10 seconds before stuff becomes visible. Again same thing after crash and restart. I've died plenty of times to invisible shit, so it's long past the point of simply irritating.
  • When I Flame Dash around, in some areas there's a few frames of what looks like area glitches, similar to dropping through floors.
  • Loading times have been extreme, with some areas not loading at all after ~2 minutes and requiring a hard reset. I'm not exaggerating when I say they are at least 5x longer than pre 3.13. This feels similar to when I had a regular HDD about 2 or 3 years ago. It's horrible.
Read more:  [opinion] Remove Hall of Grandmasters from Atlas Completion

I probably forgot a few things, but yeah, please get rid of this texture streaming or whatever it is you changed. Game performance is straight up worse than in Heist, and that is quite something. On a sidenote, my PC can handle huge packs of "Allies Cannot Die" now, but big Harbinger packs sometimes just crash me to desktop.

That's about all I could think of right now. Cheers.

Source: reddit.com

Similar Guides


More about Path of Exile

Post: "3.13 Performance Feedback from Someone Playing on a Higher End Rig" specifically for the game Path of Exile. Other useful information about this game:


Top 7 NEW Games of February 2021

Looking for something new to play on PC, PS5, PS4, Xbox, or Nintendo Switch in February 2021? Here are the notable video game releases.





Top 20 NEW Open World Games of 2021

2021 will bring us tons of open world games for PC, PS5, Xbox Series X, PS4, Switch, and beyond. Here's what we're looking forward to.


You Might Also Like

Leave a Reply

Your email address will not be published. Required fields are marked *